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Course Objectives 
 
This material is designed to assist users in understanding and applying intermediate and advanced Excel 
spreadsheet tasks. In this class, you will: 
 

 Use ranges, absolute, and relative references in a formula. 
 Use references to other worksheets and workbooks. 
 Use statistical, financial, lookup, date, and logical functions. 
 Create nested functions. 
 Prevent formulas or formatting from being changed. 
 Learn ways to customize the Excel environment. 
 Change workbook properties and worksheet settings. 
 Record and run a macro. 
 Sort and filter worksheets. 
 Create subtotals for worksheet data. 
 Create professional-looking charts. 

 
 
To begin the course, please open the exercise file  Excel Level 2 Examples 
 
 
 

A Review of Basic Formulas 
 
A few key things to keep in mind when it comes to formulas: 
 

 All formulas must begin with an equal sign (=) 
 Use the appropriate operators to specify the type of calculation you want to perform. Basic 

mathematical operators include: 
 

Operators 
^ Exponents 
* Multiplication 
/ Division 
+ Addition 
- Subtraction 

 
Excel follows a mathematical rule called order of precedence. Following operator precedence, Excel 
calculates an equation in the following order, left to right:  
 

Order of Precedence 
1st Parentheses 
2nd Exponents 
3rd Multiplication/Division 
4th Addition/Subtraction 

 
Examples: 

 
=6+3*2 Excel multiplies 3x2 then adds 6 to the result  Result: 12 
=(6+3)*2  Excel adds 6+3 then multiplies the result by 2  Result: 18 

 
You can edit a formula by clicking in the formula bar, making any necessary changes, and then pressing ENTER 
on the keyboard. 
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Cell References 
 
 

Relative Cell References 
By default, Excel interprets cell and range references within a formula as relative references. When you copy 
or move the formula, Excel automatically adjusts the references to reflect their position relative to the new 
location. In the below example, if the contents of cells B2:B18 are moved elsewhere, the AVERAGE 
function's cell references will update based on the new location of the moved cells. The same also applies if 
additional columns or rows are added. Any formulas affected by those new columns or rows will be 
automatically updated. 

 
 
The principle of relative cell references is also applied to formulas when using Auto-Fill. In the below example, 
when the formula =B2*02 in cell C2 is auto-filled down, each successive cell updates the original formula 
relative to its new location. 
 

 
To use Auto-Fill, hover over the small black square in the lower-right corner of the active cell. This is called 
the fill handle. When you hover over the fill handle, the mouse changes to a black cross hair. When it does 
this, click and drag in the desired direction. 
 
 

Auto-Fill 
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Absolute Cell References 
In most situations, relative cell references in formulas works out just fine. However, in the below example, if 
you Auto-Fill the formula =B2*B6*C6 in cell D6 down to D7, the formula will changes to =B3*B7*C7 thus 
making it useless. Your weight is in cell B2 and you don't want Excel to automatically update that reference. 

 
This can be a problem when you want to copy a formula so that a cell reference in the formula points to the 
same cell or range as in the original. You can correct this problem by using an absolute reference in the 
original formula instead of a relative one. Absolute references remain the same even when the position 
of the cell containing the formula changes. 
 
To create an absolute cell reference, enter a dollar sign ($) before the column and row reference. To quickly 
apply absolute reference to a formula, place your cursor in the center of the cell reference, then press F4 on 
your keyboard. 
 
In this example… 
Change the formula in cell D6 to =$B$2*B6*C6 and then Auto-Fill the formula to D11. Excel adjusts the 2nd 
and 3rd references relative to their new location, but left the 1st reference unchanged: =$B$2*B7*C7. 

 
 
 

Referencing a Range of Non-Contiguous Cells 
But cells in a range don’t have to be contiguous. You can define a range by selecting individual cells or groups 
of cells, separated by commas, such as =sum(B10,C9,D11). You can also mix individual cells and contiguous 
ranges in formula, such as =sum(C6:D8, B7). 
 
To enter a reference to an entire row or column, use the row number or column letter as both halves of the 
range reference, such as B:B or 2:2. 
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Referencing Other Worksheets or Workbooks 
Sometimes it’s helpful to use references to cells and ranges on other worksheets or workbooks. A formula 
containing these external references allows you to use data from other worksheets or workbooks to 
calculate new values based on this data. In the example below, cell B20 is referencing data on the National 
sheet. 

 
 
The following table contains formulas with relative references to other cells within the same worksheet, 
workbook, and different workbooks: 
 
 

Example Formula What It Does 

=C2 Uses the value in cell C2 

=Sheet2!B2 Uses the value in cell B2 on Sheet2 

=[Data]Sheet3!$E$7 Uses the value in cell E7 on Sheet3 of the workbook named Data 

 
 
If the worksheet or workbook name contains spaces, it must be surrounded by single quotation marks. For 
instance: ='Calorie Counter'!F10 
 
Three Dimensional (3D) References 
References made to another workbook, or file, are called 3D references. The three dimensions are: FILE NAME, 
SHEET NAME and CELL NAME. Also, their cell references are absolute. 
 

1. Click the cell in which you want to enter the formula.  

2. In the formula bar, type an equal sign (=). 

3. Select a cell or range of cells from another open workbook.  

4. Press Enter. 
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A Review of Basic Functions 
 
Functions are pre-written formulas that perform calculations using specific arguments in a particular order. 
Excel's over 200 built-in functions must follow certain rules. Each function must: 
 

 Begin with an equal sign 

 Be followed by the name of the function 

 Place arguments, separated by commas, within parentheses 

 
Arguments can be simple numerical values, text strings, cell references, and even other formulas and 
functions.  
 
 
By using the appropriate function for any given operation, you can accurately calculate statistical information 
for ranges of data. In this section, we’ll review the most common functions: SUM, COUNT, MAX, MIN and 
AVERAGE. 
 
 
SUM Function: You can determine the total number of products in stock by using a function which adds all of 
the numbers in a range of cells. (Including an empty cell in the range for MOST functions will not affect the 
accuracy of the results returned. Only cells containing data are calculated.) 
 

1. Click on the Merchandise sheet. 

2. Go to cell C59. 

3. From the Home tab, click the AutoSum button. 

4. Excel correctly guesses the range on which to perform the 
calculation. 

5. Press Enter. 

 

 
 
 
COUNT NUMBERS Function: You can calculate the total number of products listed in this table by using a 
function which will count the number of cells in column C that contain numbers. 
 

1. Go to cell C60.  
2. From the AutoSum drop-down list, click Count Numbers. 

3. This time, instead of accepting Excel's guess as to the cells we want to calculate, click and drag to 
select the range C2:C55. 

4. Press Enter to insert the function. 
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MINIMUM (MIN) Function: You can identify the lightest product in the list using a function that returns the 
smallest value in a set of arguments. 
 

1. Go to cell C61. 

2. From the AutoSum drop-down list, click Min. 

3. Click and drag to select the range D2:D55. 

4. Press Enter to insert the function. 

 

 

 
MAXIMUM (MAX) Function: You can identify the heaviest product in the list using a function that returns 
the largest value in a set of arguments. This time, let’s use the AutoSum shortcut. 
 

1. Go to cell C62. 

2.  From the AutoSum drop-down list, click Max. 

3. Click and drag to select the range D2:D55. 

4. Press Enter to insert the function. 
 
 
AVERAGE Function: You can identify the average weight of the products in the list using a function that 
returns the average of the values in a set of arguments.  
 

1. Go to cell C63. 

2. From the AutoSum drop-down list, click Average. 

3. Click and drag to select the range D2:D55. 

4. Press Enter to insert the function. 
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More Functions 
 
 

Financial Functions 
Calculating the future value of an investment or how much time it will take to pay off a loan can be difficult 
and time-consuming. By taking advantage of the financial functions available with Excel, you can quickly 
complete common business calculations. 
 
 
FUTURE VALUE (FV) Function: This function returns the future 
value of an investment based on periodic, constant payments and a 
constant interest rate. As part of the employee benefits package, we 
can invest in a Roth IRA account. Let’s calculate the estimated future 
value of any investment made to that account. 
 

1. In our example file, click the Investment sheet. 

2. Go to cell D9. 

3. From the Formulas tab, click the Financial category 
and select FV from the list. 

 
 
 
 
 
 
 

FV Function Arguments 
5. Rate: enter the interest rate by selecting cell D6. 

6. Nper: enter the total number of payment periods in the investment by selecting cell D7. 

7. PMT: enter the annual contribution by selecting cell D8. 

8. Because the contributions are monthly, multiply PMT by 12 to calculate the annual contribution. 
Therefore, PMT should read D8*12. 

9. The last two arguments are optional, but click in the Type box. 

10. Because the payments will be made at the beginning of each month, type 1. 

11. Click OK. 
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PAYMENT (PMT) Function: This function calculates the monthly payments for a loan based on constant 
payments and a constant interest rate. To perform the appropriate calculations, the PMT() function requires 
an interest rate, the number of months of payments, and the starting balance.  
 

1. In our example file, click the Loan sheet. 

2. Go to cell D9. 

3. From the Formulas tab, click the Financial category 
and select PMT from the list. 

 
PMT Function Arguments 
4. Rate: enter the interest rate for the loan by selecting cell 

D6 

5. Because the interest rate on the worksheet is an annual 
rate, you calculate monthly payments by dividing the rate 
by 12. Therefore, Rate should read D6/12 

6. Nper: enter the number of monthly payments for the loan 
by selecting cell D7 

7. PV: enter the present value of the loan by selecting cell D8 

8. Leaving the FV argument blank will indicate that the final balance of the loan is zero 

9. If the Type field is left blank, it assumes the payment is made at the end of each period. If you 
enter 1 in this field, it assumes the payment is made at the beginning of each period. 

10. Click OK. 
 
 

 

 
 
 

Logical Functions 
Logical functions are very helpful in comparing and evaluating data. In our example file, we'll add an IF 
function to a table to automatically determine the price of an item. 
 
IF Function: This function checks whether a condition is met, and returns one value if the condition is TRUE 
and another value if the condition is FALSE. In our example, we'll use the IF function to base the price of each 
item on its weight, with one price for items weighing less than 150 pounds, and a different price for items 
weighing over than 150 pounds. 
 

1. In our example file, click the Merchandise sheet. 

2. Go to cell E2. 

3. From the Formulas tab, click the Logical category and select IF from the list 
 
The IF function includes three arguments. The Logical Test, Value if True and Value if False. The logical 
test argument must be an expression that can be evaluated as true or false.  
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IF Function Arguments 
4. Logical Test:  type D2<150 

5. Value if True:  type 3000 

6. Value if False:  type 5499 

 
The completed function should read in the Formula Bar as:  =IF(D2<150,3000,5499) 
 
This function means, if the value in cell D2 is less than 150, Excel will return a value of 3000. If the value in 
cell D2 is more than 150, Excel will return a value of 5499. 
 

7. Format the cell as ACCOUNTING, then drag the Auto-Fill handle to cell E55 to copy the formula to 
the other cells. 

 

 
 

Nesting Functions 
In some cases it may be necessary to use one function as the argument for another. Nesting functions within 
functions this way is common with logical functions such as IF. Let’s create a simple nested function to 
calculate the shipping costs for each item based on its weight. 
 

1. In our example file, click the Merchandise sheet 

2. Go to cell F2 

3. From the Formulas tab, click the Logical category and select IF from the list 
 
For this example, the shipping charges are determined by the weight of each item. If the item weighs less 
than 100 pounds, the charge is $50. If the item weighs between 100-149 pounds, the charge is $75. 
Finally, if the item weighs 150 pounds or greater, the charge is $100. 
 

IF Function Arguments 
4. Logical Test:  type D2<100 

5. Value if True:  type 50 

6. Value if False:  If the argument is false, we want to include two more options. To do this we 
"nest" another IF function within the existing function in the Value if False field. 

7. Click inside the Value if False field, then click the Function arrow, located to the left of the 
formula bar where the Name Box usually appears.  

8. Select IF from the list. 
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Nested IF Function Arguments 
9. Logical Test:  type D2<150 

10. Value if True:  type 75 

11. Value if False:  type 100 

12. Click OK 

13. Now drag the Auto-Fill handle to 
cell E59 to copy the formula to 
the other cells. 

 
 
 
 
 
 
 
The function should appear in the Formula Bar as:  =IF(D2<100,50,IF(D2<150,75,100)) 
 
This function means, if the value in cell D2 is less than 100, return a value of 50. If the value in cell D2 is 
more than 100, proceed to the second IF function. In the second IF function, if the value in cell D2 is less 
than 150, it returns a value of 75. If D2 is more than 150, it returns a value of 100. 
 
To view the completed function within the Function Arguments box, click on cell F2 then click the Insert 
Function (fx ) button. Note the Value if False field displays the entire Nested function. 
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Lookup Functions 
When you need to create worksheets that use information stored in other sheets, lookup functions can save 
you time. 
 
VLOOKUP Function: This function looks for data stored in the leftmost column of a table, and then returns 
data in the same row from a column you specify. By default, the table must be sorted in ascending order. 
 
HLOOKUP Function: This function looks for data stored in the top row of a table, and then returns the value 
in the same column from a row you specify. 
 
In our example file we'll add a function to the Invoice sheet that will retrieve the product information from the 
Merchandise sheet. 
 

1. In our example file, click the Invoice sheet. 

2. Go to cell J18. 

3. From the Formulas tab, click the Lookup & Reference category and select VLOOKUP from 
the list. 

 
 

 
 
Excel will match the value that you enter for 
the first argument to values in the leftmost 
column of the table. The Lookup_value 
argument can be a number, a cell reference, 
or text enclosed in quotation marks. When an 
invoice is filled out, the function will need to 
use the product name as the lookup value. 
 
 
 
 
 
 

 
 
 

VLOOKUP Function Arguments 
4. Lookup_value: click on cell C18. 

5. Table_array: defines the range 
that contains the product weight 
information. 

6. Click the collapse dialog button . 

7. Click the Merchandise sheet. 

8. On this worksheet, the 1st column 
contains the product names, and 
the 4th and 5th columns contain 
weight and price information. 

9. Select the range A2:E55. 

10. Click the expand dialog button . 

 
The VLOOKUP function requires the use of a number instead of a letter to identify the column containing the 
values that need to be looked up. Product weights are listed in column D, the 4th column.  
 

11. Col_index_num: type 4. 

12. Range_lookup: specifies whether the function will find an exact match or an approximate 
match. 

13. To have the function find only exact matches, type False. 
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14. Click OK. 

15. The function should appear in the Formula Bar as:  
 

=VLOOKUP(C18,Merchandise!A2:E59,4,FALSE) 
 

16. Test the function by going to cell C18 and type in Darth Gator. 

17. Press Enter. 
 
 
Copying a VLOOKUP Function 
To add a function to retrieve unit prices, you can copy the weight lookup function and make a few 
modifications in the formula bar. 
 

1. Copy the formula in cell J18 and Paste it to cell K18. 

2. You will get a #N/A error due to several relative cell references. To fix this, click on the 
original formula in cell J18 and do the following: 

o Change the Lookup value to a mixed reference $C18. In this mixed reference, the 
column is absolute, but the row is relative. 

o Change the Table_array to an absolute reference so that it won't change when 
copied: $A$2:$E$59 

3. Again, Copy the formula in cell J18 and Paste it to cell K18. You won't get an error this time, but 
the function is exactly the same and we want to return the Unit Price instead of the Weight. 
Since the weight is in the 5th column of the table array do the following: 

o Change the Col_index_num to 5. 

4. The function in cell J18 should read in the Formula Bar as: 
 

=VLOOKUP($C18,Merchandise!$A$2:$E$59,5,FALSE) 
 

 
 
Enter a formula that will add the unit price by the total number ordered. 
 

1. Click in cell L18 and enter =K18*B18 

2. Click cell B18, and type 2 

3. Press Enter 

 
 

Date & Time Functions 
When you need to perform calculations involving date and time, you can use special functions designed just 
for those calculations. Two of the most common date and time functions are TODAY and NOW. 
 
NOW Function: Returns the date and time the workbook was opened, so the value will change every time 
the workbook is opened. The NOW function is one of the few functions that doesn't have any arguments. In a 
NOW function, the time portion of the cell is not continually updated. The value can be updated in one of three 
ways: 
 

 Save and close the workbook, then reopen it  

 Press F9 on the keyboard. 

 Make an entry in the spreadsheet. 
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TODAY Function: Returns the current date. The TODAY function is one of the few functions that doesn't 
have any arguments. 
 

Inserting the TODAY Function 
1. In our example file, click the Invoice sheet. 

2. Go to cell L12. 

3. From the Formulas tab, click the Date & Time category and select TODAY from the list. 
o The TODAY function takes no arguments. 

o The formula result is volatile. 

4. To insert the function, click OK. 

 

 
 
Formulas Based on Dates 
In our example file, let's say it takes 5 days to deliver the product. Here we can simply create a formula that 
adds five to today's date. 
 

1. Click in cell L15 

2. Enter the formula =L12+5 

3. Press Enter 
 
 

Error Codes 
 
 
Excel identifies errors in several ways. The first way is to fill the cell holding the formula generating the error 
with an error code.  
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When a cell with an erroneous formula is the active cell, an Error button appears next to it. You can click the 
button’s down arrow to display a menu with options that provide information about the error and offer to help 
you fix it. The following table lists the most common error codes and what they mean. 
 
 

Error Code Description 

##### The column isn’t wide enough to display the value. 

#VALUE! The formula has the wrong type of argument (such as text where a TRUE or FALSE value is required). 

#NAME? The formula contains text that Excel doesn’t recognize (such as an unknown named range). 

#REF! The formula refers to a cell that doesn’t exist (which can happen whenever cells are deleted). 

#DIV/0! The formula attempts to divide by zero. 

#N/A This formula is unable to calculate due to missing data (such as a blank Lookup Value cell in VLOOKUP) 

 
 

Customizing Workbooks 
 

Using Freeze Panes 
If you have a large table, the column and row labels can disappear from view when you scroll through the 
data. Freezing panes allows you to select data that remains visible when scrolling in a sheet.  
 

1. Open the file  Baseball.xls 

2. On the View tab, click the Freeze Panes button and select Freeze Top Row 

o Notice that columns can also be frozen with the Freeze First Column option 

3. Scroll down and notice row 1 is always displayed 

4. To remove the frozen panes, go back to the View tab, click the Freeze Panes button and select 
Unfreeze Panes 

 

 
 
 

Hiding Rows and Columns 
If you have rows or columns with data that doesn’t need to be displayed, you can hide them from view 
without deleting them. When you need to view or manipulate hidden rows or columns, you can display them 
again. 
 

1. Select columns E thru I 

2. Right-click on one of those column headers and select Hide on the shortcut menu 

3. To unhide the columns, select columns D thru J 
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4. Right-click the selection, and click Unhide on the shortcut menu 

 
  
 

Using Split Screens 
You can divide your worksheet view into four sections, and then manipulate your view of a large worksheet by 
scrolling within each pane. To do that: 
 

1. Click cell G15 to specify where the split dividers should appear. 

2. On the View tab, click Split. 

3. Drag the divider to a new location to see more or less of a pane, and scroll to view the data. 

4. To return to normal, go to the View tab and click Split.  
 

 
 

 NOTE: You can also split the screen into two sections by dragging the split box (located at the top of the 
vertical scroll bar or at the right end of the horizontal scroll bar) to the position you want. 
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Arranging Multiple Windows 
If you want to compare or enter data on several workbooks at one time, you can open each workbook and 
then arrange the windows. 
 

1. Open several files.  

2. On the View tab, click Arrange All. 

3. Select Tiled. 

4. To return to normal view, maximize any 
workbook. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Conditional Formatting 
When you need to quickly identify items in a spreadsheet that meet a defined criterion, you can use 
conditional formatting. If the cell meets the criteria, the formatting you chose will automatically be applied. 
 
 
Conditional Formatting Templates 

1. In the Baseball.xls file, open the 2008 Batting sheet.  

2. Select column K. 

3. On the Home tab click Conditional Formatting then Data Bars and select one of the six 
colors.  
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Setting Up Your Own Conditional Formatting Options 
1. In the Excel Level 2 Examples file, open the Budget sheet.  

2. Select the range E5:F8. 

3. On the Home tab click Conditional Formatting then select New Rule. 

4. From the New Formatting Rule dialog box, select Format only cells that contain. 

5. In the first field, select Cell 
Value. 

6. In the second field, select Less 
than. 

7. In the last field, type 0. 

8. Specify the formatting to apply by 
clicking Format. 

9. Click the Color arrow and select 
Red. 

10. Click OK. 

 
 
 
 
 
 
 

 
 
 

 
 
 
 

Importing Data 
 
 

Importing Data From a Text File 
By importing data, you don't have to retype the data you want to analyze in Excel, saving you time, energy, 
and potential frustration. To import data from a text file: 
 

1. Open the file Employees.xls and click in cell A6 

2. On the Data tab, click From Text 

3. Browse for and double-click on the New Employees text file 

4. The Text Import Wizard begins, and usually guesses the 
correct information: 

o On Step 1 click Next 

o On Step 2 make sure the Delimiter is set to Comma then click Next 

o On Step 3 click Finish 

5. Click OK 
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The data is brought into the Excel spreadsheet, placed into the proper columns. However, the columns widths 
have been modified, so we’ll need to specify their widths again. One fast way to do this is to use the AutoFit 
option.  
 

6. Select columns A thru H 

7. On the Home tab and click Format > Autofit Column Width 

 
 

 
 
 
 
 

Importing Data from a Database 
In a similar fashion as Text File imports, data can be imported from a database. In this example, however you 
will not need to step through the Wizard process. 
 
 

1. In the same Employees.xls file, click in cell A10. 

2. On the Data tab select From Access. 

3. Browse for and double-click the Emlployees.mdb file 

4. This time there is no Wizard, simply click OK to import the data. 

5. The header row that Access imports with the data cannot be deleted in by right-clicking and selecting 
delete. Select the imported data from Access and click the Design tab and deselect Header Row. 

 

 
 

 



Page 19 

 

 
 

Summarizing Spreadsheet Information 
 
 

Sorting Data 
Because data is often added to a list in no particular order, you can use Excel to sort a list alphabetically or 
numerically. A quick way to sort a list is to use the Sort Ascending and Sort Descending buttons.  
 

1. Click in the column you wish to sort by 

2. On the Home tab, click the Sort & Filter button 

3. Select the A-Zor Z-A button 

 
 

 
 
 
Custom Sort 
You can also sort by more than one column. 
 

1. On the Home tab, click the Custom Sort button 

2. Select your desired Column, Sort On and Order 

3. Click the Add Level button to sort by another level 

4. You can add as many levels as you like 

5. Click OK 
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Filtering Information 
To view and work with specific data in a list, you can filter the list, rather than rearrange it, enabling you to 
temporarily hide rows that you don't want displayed.  
 

1. On the Data tab, click Filter 
 
The AutoFilter command displays arrows next to the column labels in the list. When you click the AutoFilter 
arrow next to a column label, you’ll see a list that includes one entry for each category in the column. 
 

2. Click the AutoFilter arrow next to the desired 
column and choose Select All to remove all 
check marks 

3. Place a check mark next to the value you want 
to filter by 

4. To remove the applied filter, click the Filter 
button on the Home tab 

 

 
 
 
 
 
 
 
 
 
 
Custom Filters 
Another way to view a specific set of data is with a custom filter. In the Custom AutoFilter dialog box, you can 
select a filtering operation and enter a value from the worksheet.  
 

1. Click the AutoFilter arrow next to a column containing numbers and select Number Filters 

2. From the menu, click Greater Than Or Equal To 

3. Enter your desired number 

4. Click OK 
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Using Subtotals 
Using Excel, you can summarize data in a list by calculating subtotals and grand totals.  
 

1. Open the Fines.xls file and click in cell A1 

2. On the Data tab, click Subtotals 

 
Now you must specify the column that contains the items or groups by which 
you want to subtotal values in other columns and which function to use.  
 

3. Click the At Each Change In arrow, and click City 

4. Leave the default Use Function item to calculate the total 

5. In the Add subtotal to list, select Revenue 

6. Leave the Summary below data check box selected to calculate 
subtotals and a grand total 

7. Click OK 

 
 
The list now contains a subtotal for each city. When you insert subtotals, Excel 
outlines the list by grouping detail rows with an associated subtotal row. You 
can click the outline headers to view specific sections of the worksheet. To view 
just the subtotals for each city, along with the grand total: 
 

 Click the 2 outline header. 
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Charts & Graphs 
 
Charts are designed to help users more easily see comparisons, patterns, and trends in data. Choosing the 
right chart can make a big difference when it comes to presenting and analyzing information. Excel includes 
14 basic chart types, each of which includes sub-types or variations. You can browse through the available 
types and subtypes to find the chart type that will represent your data most effectively. The most common 
types of charts used for business purposes are Column charts, Bar charts, Line charts, and Pie charts.  
 
 

Create a Chart 
When you want to get a quick start on illustrating the data stored in a worksheet, you can use the Chart 
Wizard. Let’s create a chart using the subtotals on this worksheet. To begin, you need to select the range of 
cells containing the data series you want to present as a chart.  
 

1. In the Fines.xls file, click the Budget tab 

2. Select the range A1:C7 

3. On the Insert tab, select the Column category then one of the 3-D types 
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The Chart Tools Contextual Tab 
Use the Chart Tools contextual tab to modify the style of your chart. From the Design sub-tab the Chart 
Layouts gallery provides 10 different layout options. The Chart Styles gallery helps you make quick 
changes to colorization. 
 
 
 
 
 
 
 
 

 
 
If none of the options from the Chart Layouts group are satisfactory, you can make your own modifications 
by using the Layout sub-tab; especially the Labels group. 
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Advanced Chart Customization 
The overall appearance of a chart can be changed via the CHANGE CHART TYPE button on the CHART TOOLS – 

DESIGN tab. With this you can change from a flat chart style to a 3-D style or convert, say, a pie chart to a bar 
chart. More subtle, but visually appealing, changes can be made to a chart from the FORMAT DATA SERIES dialog 
box. The example below illustrates several of these subtle changes. 

 
 
To apply the changes found on the customized chart, follow the directions below: 
 

1. Begin by right-clicking on a pie piece and select FORMAT DATA SERIES. 

2. Choose the 3-D FORMAT category. 

3. In the BEVEL area, choose a bevel style for the TOP and BOTTOM 

4. Apply a point size to the WIDTH and HEIGHT for the TOP and BOTTOM bevel (while the example below uses 
a 500 POINT size, enter your own desired point size.) 

5. To add a surface effect, select a style from the SURFACE MATERIAL area. 

6. To modify the chart border, right click on the chart border and select FORMAT CHART AREA. 

7. From the BORDER STYLES category, choose rounded corners 

8. From the SHADOW category, you can choose a shadow style from the PRESETS list  
 

Customized Pie Chart 
Shadow, Beveled Edge, Rounded & Shadowed Border, Surface Shine 

Standard Pie Chart 
Standard 3-D, Exploded Pie Chart 
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1. Open the Excel Level 2 Practice.xls file to the Merchandise tab. 

2. In cell B18, calculate the total number of items using the COUNT NUMBERS function. 

3. In cell B19, calculate the total number of items in stock using SUM function. 

4. In cell B20, calculate the average price of items using the AVERAGE function. 

5. In cell B21, calculate the maximum price of items using the MAX function. 

6. In cell B22, calculate the minimum price of items using the MIN function. 

7. In cell E2, create a nested IF function to calculate the shipping cost so that items 
weighing less than 50 pounds costs $15 to ship, items weighing between 50-99 
pounds costs $25 to ship, and items weighing 100 pounds or more costs $35 to 
ship. 

8. Using the AutoFill handle, copy the formula in cell E2 to cells E3:E16. 

9. Click the Invoice tab. 

10. In cell M12, insert the NOW function so that the date is updated each time the 
worksheet is opened or refreshed. 

11. In cell M15, enter a formula which will calculate the payment due date of 14 days 
from today. 

12. In cell K18, insert a VLOOKUP function to display the weight of an item entered into 
cell C18. Change the range for the table to absolute references. Using the AutoFill 
handle, copy the formula to cell K24. 

13. In cell L18, insert a VLOOKUP function to display the price of an item entered into cell 
C18. Change the range for the table to absolute references. Using the AutoFill handle, 
copy the formula to cell L24. 

14. Test your formulas: Enter a QTY and ITEM into cells B18 and C18. Press ENTER. If the 
weight and price appear in cells K18 and L18, your formulas are correct. 

15. Click the Investment tab. In cell D9, insert a FV function to determine the future 
value of the investment. 

16. Click the Loan tab. In cell D9, insert a PMT function to determine the monthly 
payment of the loan. 

 
 



 

Worksheet Function Categories 
 
You can add functions to your formulas to perform more advanced numerical and text processing operations in 
worksheets. A function is a predefined equation that operates on one or more values and returns a single 
value. Excel includes more than 200 built-in functions organized in 11 categories. The table below lists each 
category and describes its general use.  
 

Category Functions Used For 

Database Working with external databases and lists 

Date and Time Calculations involving date and time 

External Converting euro currency, and connecting to external data sources 

Engineering Performing common engineering calculations 

Financial Determining appreciation, depreciation, interest, payments, and other 
common calculations 

Information Determining if an error has occurred in a calculation 

Logical Calculations that produce a result of TRUE or FALSE 

Lookup and Reference Calculations involving tables of data 

Math and Trigonometry Mathematical and trigonometric calculations similar to those found on a 
scientific calculator 

Statistical Determining average, standard deviation, sum, variance, and other common 
calculations 

Text and Data Comparing, converting, and reformatting text within cells 

 
 

Formula and Function Shortcuts 
 
When you’re working with formulas and functions, there are many useful keyboard shortcuts you can use to 
increase your efficiency. Some of the more helpful shortcuts are listed in the table below. For additional 
information about keyboard shortcuts, you can type shortcuts in the Office Assistant or on the Answer 
Wizard tab in the Excel Help window, and click Search. 
 
 

To do this: Press this: 

Open the Insert Function dialog box to insert a function Shift + F3 

Insert an AutoSum formula  Alt + =  (equal sign) 

Insert the argument names and parentheses for a function after you type 
a function name in a formula 

Ctrl + Shift + A 

Open the Function Arguments dialog box after you type a function name 
in a formula 

Ctrl + A 

Create names from row and column labels Ctrl + Shift + F3 

Paste a defined name into a formula F3 

Switch between displaying cell values and cell formulas Ctrl + ` (Single left 
quotation mark) 

Calculate all sheets in all open workbooks, or 
Calculate the selected portion of a formula 

F9 

Calculate the active worksheet Shift + F9 

 
 
 



 

Chart Types 
 
The types of charts available in Excel are described in the table below.  
 
 
Chart Type Example Description 
Column 

 

Column charts display categories on the horizontal axis and 
the category data on the vertical axis. Column charts are 
commonly used to show financial data over time. You can also 
show the relationship of your data to totals by using a stacked 
column chart. 

Bar 

 

Bar graphs compare data across categories. The categories 
are shown along the vertical axis while the data is shown 
along the horizontal axis.  

Line 

 

A line graph is similar to a bar graph, the only difference is 
that a line is drawn from value to value instead of bars. Line 
charts are best used to show trends over time or by category.  

Pie 

 

Pie charts show what percentage each data value contributes 
to the whole. Pie charts are best suited for datasheets with 
only one row or column. 

Scatter 

 

A scatter chart is used for comparing pairs of values. A 
scatter chart is particularly useful to draw relationships 
between the numerical data presented in both the categories 
and the series. 

Area 

 

An area chart displays the trend of values over time or 
categories. Area charts are plotted like line charts, with the 
area under the lines filled in. Because of the fill, area charts 
are best particularly suited for slides. 

Doughnut 

 

A doughnut chart is similar to a pie chart, and has the 
advantage of being able to be used for data with more than 
one series.  

Radar 

 

A radar chart compares the values of several data series 
relative to a center point using a radar chart. Each category 
has its own value axis radiating out from the center, and lines 
connect all the values in a series. This type of chart is usually 
used for scientific data. 

Surface 

 

A surface chart can be used when you have two series of 
data. The data is plotted like a line graph and then connected 
to create a ribbon-like surface. 

Bubble 

 

A bubble chart enables you to plot three series of data. The 
data is represented by values on the horizontal axis, the 
vertical axis, and by the size of each bubble. 

Stock 

 

A stock chart is designed specifically to plot stock prices. The 
simplest version plots high, low, and closing prices. 

 


